User Community Service Desk Downloads
If you can't find the product or version you're looking for, visit support.ataccama.com/downloads

Supported Third-Party Components

Here you can find a list of key third-party components that Ataccama ONE requires or can integrate with as well as their recommended or supported versions. In case we advise using a specific version, that version is listed as recommended even though other supported versions might function without issues.

We differentiate between recommended and supported versions:

  • Recommended: The version is actively tested for each release.

  • Supported: The application should run on this version but the compatibility is not verified for each release. Instead, it is tested once in a major release and we rely on the backward compatibility of the third-party software provider.

Operating systems

Ataccama ONE can be deployed on the following OS and accessed using the following web browsers.

Product Recommended Supported

DQG, MDM, RDM

Red Hat Enterprise Linux 9.x

Red Hat Enterprise Linux 8.x, Ubuntu 22.04 LTS

ONE Desktop

Windows 11, MacOS Latest stable version

Windows 10, Ubuntu 22.04

Identity and access management

Product Recommended Supported

DQG, MDM, RDM

Keycloak 23

Keycloak 23+

Java

Product Recommended Supported

DQG

Java 17

MDM, RDM

Open JDK 17, Oracle Java 17

Databases

Product Recommended Supported

DQG

PostgreSQL 15

PostgreSQL 13+

MDM, RDM

PostgreSQL 15

PostgreSQL 13

Oracle 23

Oracle 19

MS SQL Server 2022

Azure SQL

Amazon Aurora PostgreSQL

Notes

Amazon Aurora PostgreSQL configuration for MDM

If the apg_plan_mgmt extension is enabled, set the apg_plan_mgmt.use_plan_baselines to false. Any other configuration should be confirmed by your database administrator.

Web browsers

Component Recommended

Google Chrome

121.x, 120.x

Microsoft Edge

121.x, 120.x

Mozilla Firefox

122.x, 121.x

Safari

17.3, 17.2

ONE Desktop components

Recommended Supported

Eclipse 4.29

Other third-party applications

To function correctly, Ataccama ONE requires the following third-party components. These dependencies are installed using Ansible, with some exceptions in which a dedicated installation package must be used instead.

The supported Ansible version is 4.5.

Object Storage

Component Recommended

MinIO

RELEASE.2024-01-01T16-36-33Z-1

Search engine

Component Recommended

OpenSearch (for logging and monitoring and as search engine in ONE)

2.11.0

Logging and monitoring

Component Recommended

Prometheus

2.31.1

Grafana

9.5.10

OpenSearch Dashboards

2.11.0

The version must match the one used for OpenSearch.

Alertmanager

0.26.0

Prometheus Node Exporter

1.6.1

Prometheus Process Exporter

0.7.10

Prometheus PostgreSQL Server Exporter

0.10.0

NGINX Prometheus Exporter

0.9.0

Prometheus Elasticsearch Exporter

N/A

Prometheus JMX Exporter

0.20.0

FluentD

4.4.0

FluentBit

1.9.9

Kibana

N/A

Kibana Exporter plugin

N/A

Python

Component Recommended

Python

3.11.4

MANTA

Component Recommended

MANTA

41.1.11

Ansible dependencies

Component Recommended

NGINX Web Server

1.25.4-1

Tomcat

10.1.18

Messaging

Depending on the specific functionalities of Ataccama ONE that you use, the application might rely on the following components.

Component Recommended

Message Broker

Latest stable version

JMS Supporting Platforms

JMS 1.1

Apache ActiveMQ

5.0+

ApolloMQ

1.6+

Tibco EMS

8.0+

IBM WebSphere MQ

7.0+

Streaming

Depending on the specific functionalities of Ataccama ONE that you use, the application might rely on the following components.

Component Recommended Supported

Apache Kafka

3.1-3.4

2.4-2.8

Was this page useful?